Back to overview
Resolved
JettRequest Outage
May 29, 2026 at 6:55pm UTC
Resolved
Jun 18, 2026 at 1:49am UTC
JettRequest is now Seerr
Access it at https://seerr.j4.ke
Affected services
Created
May 29, 2026 at 6:55pm UTC
JettRequest/Seerr will be temporary down from May 29th to June 14. We will update JettRequest to the newest version of Seerr. The new URL will be https://seerr.j4.ke
Updated 14:50 05 June 2026 ET
Affected services